设为首页收藏本站帮助中心
查看: 541|回复: 0
收起左侧

易语言实现长整数型自增ID 长整数型与字节集数据互转 (8字节储存ID,程序运行次数计数)

[复制链接]
发表于 2020-4-8 22:42:23 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. 信息框 (“程序第” + 到文本 (自增ID ()) + “次运行!”, 0, , )


  8. .子程序 写ID, 逻辑型, 公开, 成功返回真,失败返回假
  9. .参数 ID, 长整数型

  10. 返回 (写到文件 (“id.dat”, 到字节集 (ID)))

  11. .子程序 读ID, 长整数型, 公开

  12. 返回 (取字节集数据 (读入文件 (“id.dat”), #长整数型, ))


  13. .子程序 自增ID, 长整数型, 公开, ID+1 成功返回ID,失败返回0
  14. .局部变量 ID, 长整数型

  15. ID = 长整数_相加 (读ID (), 1)
  16. .如果真 (写ID (ID) = 假)
  17.     返回 (0)
  18. .如果真结束
  19. 返回 (ID)



  20. .子程序 长整数_相加, 长整数型
  21. .参数 被加数, 长整数型
  22. .参数 加数, 长整数型

  23. 置入代码 ({ 139, 69, 8, 139, 85, 12, 3, 69, 16, 19, 85, 20, 201, 194, 16, 0 })
  24. ' mov eax,[ebp+8]
  25. ' mov edx,[ebp+12]
  26. ' add eax,[ebp+16]
  27. ' adc edx,[ebp+20]
  28. ' leave
  29. ' retn 16
  30. 返回 (0)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则