设为首页收藏本站帮助中心
查看: 436|回复: 0
收起左侧

易语言MASM置入代码实现检测字节集 (字节型数组) 中是否包含空字符 {0} (返回逻辑型)

[复制链接]
发表于 2020-4-15 20:56:17 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (字节集_是否存在空字符 ({ 1, 2, 3, 4 }))
  9. 输出调试文本 (字节型数组_是否存在空字符 ({ 5, 6, 7, 8 }))
  10. 输出调试文本 (字节集_是否存在空字符 ({ 1, 2, 3, 4, 0 }))
  11. 输出调试文本 (字节型数组_是否存在空字符 ({ 5, 6, 7, 8, 0 }))
  12. 输出调试文本 (字节集_是否存在空字符_易源码 ({ 5, 6, 7, 8, 0 }))
  13. 输出调试文本 (字节集_是否存在空字符_易源码 ({ 1, 1, 1, 1 }))

  14. .子程序 字节集_是否存在空字符_易源码, 逻辑型
  15. .参数 数据, 字节集

  16. 返回 (寻找字节集 (数据, { 0 }, ) ≠ -1)

  17. .子程序 字节集_是否存在空字符, 逻辑型, 公开, 找到空字符 {0} 返回真,否则返回假
  18. .参数 数据, 字节集

  19. 置入代码 ({ 83, 81, 82, 139, 69, 8, 11, 192, 117, 2, 235, 47, 139, 0, 11, 192, 117, 2, 235, 39, 139, 88, 4, 11, 219, 117, 4, 51, 192, 235, 28, 131, 192, 8, 51, 201, 235, 15, 138, 20, 1, 10, 210, 117, 7, 184, 1, 0, 0, 0, 235, 7, 65, 59, 203, 114, 237, 51, 192, 90, 89, 91, 201, 194, 4, 0 })
  20. ' push ebx
  21. ' push ecx
  22. ' push edx
  23. ' mov eax,[ebp+8]
  24. ' .if eax == 0
  25. ' jmp ASM_END
  26. ' .endif
  27. ' mov eax,[eax]
  28. ' .if eax == 0
  29. ' jmp ASM_END
  30. ' .endif
  31. ' mov ebx,[eax+4]
  32. ' .if ebx == 0
  33. ' xor eax,eax
  34. ' jmp ASM_END
  35. ' .endif
  36. ' add eax,8
  37. ' xor ecx,ecx
  38. ' .while ecx < ebx
  39. ' mov dl,[eax+ecx]
  40. ' .if dl == 0
  41. ' mov eax,1
  42. ' jmp ASM_END
  43. ' .endif
  44. ' inc ecx
  45. ' .endw
  46. ' xor eax,eax
  47. ' ASM_END:
  48. ' pop edx
  49. ' pop ecx
  50. ' pop ebx
  51. ' leave
  52. ' retn 4

  53. 返回 (假)

  54. .子程序 字节型数组_是否存在空字符, 逻辑型, 公开, 找到空字符 {0} 返回真,否则返回假
  55. .参数 数据, 字节型, 数组

  56. 置入代码 ({ 83, 81, 82, 139, 69, 8, 11, 192, 117, 2, 235, 47, 139, 0, 11, 192, 117, 2, 235, 39, 139, 88, 4, 11, 219, 117, 4, 51, 192, 235, 28, 131, 192, 8, 51, 201, 235, 15, 138, 20, 1, 10, 210, 117, 7, 184, 1, 0, 0, 0, 235, 7, 65, 59, 203, 114, 237, 51, 192, 90, 89, 91, 201, 194, 4, 0 })
  57. ' push ebx
  58. ' push ecx
  59. ' push edx
  60. ' mov eax,[ebp+8]
  61. ' .if eax == 0
  62. ' jmp ASM_END
  63. ' .endif
  64. ' mov eax,[eax]
  65. ' .if eax == 0
  66. ' jmp ASM_END
  67. ' .endif
  68. ' mov ebx,[eax+4]
  69. ' .if ebx == 0
  70. ' xor eax,eax
  71. ' jmp ASM_END
  72. ' .endif
  73. ' add eax,8
  74. ' xor ecx,ecx
  75. ' .while ecx < ebx
  76. ' mov dl,[eax+ecx]
  77. ' .if dl == 0
  78. ' mov eax,1
  79. ' jmp ASM_END
  80. ' .endif
  81. ' inc ecx
  82. ' .endw
  83. ' xor eax,eax
  84. ' ASM_END:
  85. ' pop edx
  86. ' pop ecx
  87. ' pop ebx
  88. ' leave
  89. ' retn 4

  90. 返回 (假)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则