设为首页收藏本站帮助中心
查看: 749|回复: 0
收起左侧

易语言MASM置入代码实现文本型变量的指针与指定整数型数值相加 (无返回值)

[复制链接]
发表于 2020-4-27 21:30:04 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 文本, 文本型

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. 文本 = “GET /test HTTP/1.0”
  11. 输出调试文本 (易源码 (文本, 5))
  12. 输出调试文本 (“相加前:” + 到文本 (取变量数据地址 (文本)))
  13. 文本指针_相加 (文本, 5)
  14. 输出调试文本 (“相加后:” + 到文本 (取变量数据地址 (文本)))
  15. 调试输出 (文本)


  16. .子程序 文本指针_相加, , 公开, 文本型指针与指定整数型数值相加 (严禁越界、负数、空文本、提供文本常量,否则会出错)
  17. .参数 文本, 文本型, 参考, 文本=取文本右边(文本,取文本长度 (文本)-位数)
  18. .参数 位数, 整数型

  19. 置入代码 ({ 80, 83, 81, 139, 69, 8, 139, 77, 12, 139, 24, 3, 217, 137, 24, 89, 91, 88 })
  20. ' push eax
  21. ' push ebx
  22. ' push ecx
  23. ' mov eax,[ebp+8]
  24. ' mov ecx,[ebp+12]
  25. ' mov ebx,[eax]
  26. ' add ebx,ecx
  27. ' mov [eax],ebx
  28. ' pop ecx
  29. ' pop ebx
  30. ' pop eax



  31. .子程序 易源码, 文本型
  32. .参数 文本, 文本型
  33. .参数 位数, 整数型

  34. 返回 (取文本右边 (文本, 取文本长度 (文本) - 位数))

复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则