设为首页收藏本站帮助中心
查看: 621|回复: 0
收起左侧

易语言MASM置入代码使用堆栈实现分配内存空间 (访问整数型数组空间) (无返回值)

[复制链接]
发表于 2020-5-6 17:59:44 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 下标, 整数型


  9. .变量循环首 (0, 8, 1, 下标)
  10.     调试输出 (汇编 (下标), 数组访问 (下标))
  11. .变量循环尾 ()



  12. .子程序 汇编, 整数型
  13. .参数 下标, 整数型

  14. 置入代码 ({ 106, 1, 106, 10, 106, 50, 106, 100, 104, 244, 1, 0, 0, 104, 232, 3, 0, 0, 104, 208, 7, 0, 0, 104, 136, 19, 0, 0, 104, 16, 39, 0, 0, 139, 69, 8, 139, 4, 132, 201, 194, 4, 0 })
  15. ' push 1
  16. ' push 10
  17. ' push 50
  18. ' push 100
  19. ' push 500
  20. ' push 1000
  21. ' push 2000
  22. ' push 5000
  23. ' push 10000
  24. ' mov eax,[ebp+8]
  25. ' mov eax,[esp+eax*4]
  26. ' leave
  27. ' retn 4

  28. 返回 (0)

  29. .子程序 数组访问, 整数型
  30. .参数 下标, 整数型
  31. .局部变量 数组, 整数型, , "0"

  32. 数组 = { 10000, 5000, 2000, 1000, 500, 100, 50, 10, 1 }
  33. 返回 (数组 [下标 + 1])
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则