设为首页收藏本站帮助中心
查看: 489|回复: 0
收起左侧

易语言实现添加与清除UTF-8编码字节集字符串数据开头的BOM签名 (0xEFBBBF)

[复制链接]
发表于 2020-5-8 17:14:41 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1, , , 未完成

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 数据, 字节集

  9. 数据 = 读入文件 (“utf8.txt”)
  10. 调试输出 (数据)
  11. 输出调试文本 (字节集_UTF8清除BOM (数据))
  12. 写到文件 (“utf8.txt”, 数据)
  13. 调试输出 (数据)
  14. 数据 = 字节集_UTF8添加B0M (数据)
  15. 调试输出 (数据)
  16. 数据 = 字节集_UTF8添加B0M (数据)
  17. 调试输出 (数据)


  18. .子程序 字节集_UTF8清除BOM, 逻辑型, 公开, 字节集开头为 0xEFBBBF 则清除字节集开头的该3字节并返回真,否则不修改字节集任何数据并且并且返回假
  19. .参数 UTF8数据, 字节集, 参考, 必须提供字节集变量

  20. .如果真 (位与 (取字节集数据 (UTF8数据, #整数型, ), #白色) = 12565487)
  21.     UTF8数据 = 取字节集右边 (UTF8数据, 取字节集长度 (UTF8数据) - 3)
  22.     返回 (真)
  23. .如果真结束
  24. 返回 (假)



  25. .子程序 字节集_UTF8添加B0M, 字节集, 公开, 字节集开头添加 0xEFBBBF 字样,如果已存在则不添加
  26. .参数 UTF8数据, 字节集, , 由核心库的 文本到UTF8 () 返回

  27. .如果真 (位与 (取字节集数据 (UTF8数据, #整数型, ), #白色) = 12565487)
  28.     返回 (UTF8数据)
  29. .如果真结束
  30. 返回 ({ 239, 187, 191 } + UTF8数据)


复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则