设为首页收藏本站帮助中心
查看: 453|回复: 0
收起左侧

易语言调用 wmic.exe 命令行实现设置进程优先级 (成功返回真,失败返回假,返回逻辑型)

[复制链接]
发表于 2020-5-9 23:02:33 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (置进程优先级_WMIC (“explorer.exe”, 5))


  9. .子程序 置进程优先级_WMIC, 逻辑型, 公开, 调用 wmic.exe 设置进程优先级,成功返回真,失败返回假
  10. .参数 进程名, 文本型, , 例如:explorer.exe (进程不存在将失败)
  11. .参数 优先级, 字节型, , 0:低 1:低于标准 2:普通 3:高于标准 4:高 5:实时
  12. .局部变量 优先级_常量, 文本型, 静态, "0"
  13. .局部变量 临时文件名, 文本型
  14. .局部变量 命令行, 文本型
  15. .局部变量 返回结果, 文本型

  16. .如果真 (删首尾空 (进程名) = “” 或 优先级 > 5)
  17.     返回 (假)
  18. .如果真结束
  19. .如果真 (取数组成员数 (优先级_常量) = 0)
  20.     优先级_常量 = 分割文本 (“Idle|Below Normal|Normal|Above Normal|High Priority|Realtime”, “|”, )
  21. .如果真结束
  22. 临时文件名 = 取临时文件名 ()
  23. 命令行 = “cmd /c wmic.exe process where name='” + 删首尾空 (进程名) + “' call SetPriority ” + #引号 + 优先级_常量 [优先级 + 1] + #引号 + “ >” + 临时文件名
  24. .判断开始 (运行 (命令行, 真, #隐藏窗口) = 假)
  25.     删除文件 (临时文件名)
  26.     返回 (假)
  27. .判断 (取文件尺寸 (临时文件名) ≤ 0)
  28.     删除文件 (临时文件名)
  29.     返回 (假)
  30. .默认

  31. .判断结束
  32. 返回结果 = 到文本 (读入文件 (临时文件名))
  33. 删除文件 (临时文件名)
  34. 返回 (寻找文本 (返回结果, “No Instance(s) Available.”, , 真) = -1)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则