设为首页收藏本站帮助中心
查看: 28|回复: 1
收起左侧

易语言实现检测文本型HTML代码中是否包含<base>标签的href属性(返回逻辑型)

[复制链接]
发表于 2020-5-12 18:57:37 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
本帖最后由 CNWTEPRG 于 2020-5-12 18:57 编辑

1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (是否包换base标签href属性 (“<base href=test>”))
  9. 输出调试文本 (是否包换base标签href属性 (“<base target=_blank href=test>”))
  10. 输出调试文本 (是否包换base标签href属性 (“<base target=_blank>”))




  11. .子程序 是否包换base标签href属性, 逻辑型
  12. .参数 html代码, 文本型
  13. .局部变量 H, 文本型

  14. H = 到小写 (删全部空 (html代码))
  15. H = 子文本替换 (H, #引号, , , , 假)
  16. H = 子文本替换 (H, “'”, , , , 假)
  17. H = 子文本替换 (H, “target=”, , , , 假)
  18. H = 子文本替换 (H, “_blank”, , , , 假)
  19. H = 子文本替换 (H, “_parent”, , , , 假)
  20. H = 子文本替换 (H, “_self”, , , , 假)
  21. H = 子文本替换 (H, “_top”, , , , 假)
  22. 返回 (寻找文本 (H, “<basehref=”, , 真) ≠ -1)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则