设为首页收藏本站帮助中心
查看: 373|回复: 0
收起左侧

易语言实现整数型数字按大小范围分类 (返回文本型:1~99,100~199,200~499,500~999...)

[复制链接]
发表于 2020-5-14 19:16:33 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。

  8. 输出调试文本 (数字分类 (1))
  9. 输出调试文本 (数字分类 (10))
  10. 输出调试文本 (数字分类 (100))
  11. 输出调试文本 (数字分类 (1000))
  12. 输出调试文本 (数字分类 (10000))

  13. .子程序 数字分类, 文本型
  14. .参数 数字, 整数型

  15. .判断开始 (数字 ≥ 1 且 数字 ≤ 99)
  16.     返回 (“1~99”)
  17. .判断 (数字 ≥ 100 且 数字 ≤ 199)
  18.     返回 (“100~199”)
  19. .判断 (数字 ≥ 200 且 数字 ≤ 499)
  20.     返回 (“200~499”)
  21. .判断 (数字 ≥ 500 且 数字 ≤ 999)
  22.     返回 (“500~999”)
  23. .判断 (数字 ≥ 1000 且 数字 ≤ 1999)
  24.     返回 (“1000~1999”)
  25. .判断 (数字 ≥ 2000 且 数字 ≤ 4999)
  26.     返回 (“2000~4999”)
  27. .判断 (数字 ≥ 5000 且 数字 ≤ 9999)
  28.     返回 (“5000~9999”)
  29. .判断 (数字 ≥ 10000)
  30.     返回 (“10000+”)
  31. .默认

  32. .判断结束
  33. 返回 (“0”)
复制代码


相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则