设为首页收藏本站帮助中心
查看: 6|回复: 0
收起左侧

易语言1行代码实现取文本型字符串转换到UTF8编码后的总长度 (返回整数型)

[复制链接]
发表于 3 天前 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (取文本长度_UTF8 (“Hello World!中文测试”))
  9. 输出调试文本 (取文本长度 (“Hello World!中文测试”))

  10. .子程序 取文本长度_UTF8, 整数型, 公开
  11. .参数 文本数据, 文本型

  12. 返回 (取字节集长度 (文本到UTF8 (文本数据)))
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则