设为首页收藏本站帮助中心
查看: 371|回复: 0
收起左侧

易语言实现整数型星期范围时间戳 (0~604799999) 与星期、时、分、秒、毫秒的互转

[复制链接]
发表于 2020-5-23 16:37:59 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 整数, 整数型
  9. .局部变量 星期, 字节型
  10. .局部变量 时, 字节型
  11. .局部变量 分, 字节型
  12. .局部变量 秒, 字节型
  13. .局部变量 毫秒, 短整数型

  14. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  15. 整数 = 星期时分秒毫秒_到星期时间戳 (4, 12, 34, 56, 789)
  16. 整数_到星期时分秒毫秒 (整数, 星期, 时, 分, 秒, 毫秒)
  17. 调试输出 (整数, 星期, 时, 分, 秒, 毫秒)



  18. .子程序 星期时分秒毫秒_到星期时间戳, 整数型, 公开, 失败返回-1
  19. .参数 星期, 字节型, , 0~6 (星期日为0,星期一为1)
  20. .参数 时, 字节型, , 0~23
  21. .参数 分, 字节型, , 0~59
  22. .参数 秒, 字节型, , 0~59
  23. .参数 毫秒, 短整数型, 可空, 0~999 (留空为0)

  24. .如果真 (星期 > 6 或 时 > 23 或 分 > 59 或 秒 > 59 或 毫秒 > 999 或 毫秒 < 0)
  25.     返回 (-1)
  26. .如果真结束
  27. 返回 (星期 × 86400000 + 时 × 3600000 + 分 × 60000 + 秒 × 1000 + 毫秒)


  28. .子程序 整数_到星期时分秒毫秒, 逻辑型, 公开
  29. .参数 整数, 整数型, , 0~604799999
  30. .参数 星期, 字节型, 参考
  31. .参数 时, 字节型, 参考
  32. .参数 分, 字节型, 参考
  33. .参数 秒, 字节型, 参考
  34. .参数 毫秒, 短整数型, 参考 可空

  35. .如果真 (整数 < 0 或 整数 > 604799999)
  36.     返回 (假)
  37. .如果真结束
  38. 毫秒 = 整数 % 1000
  39. 秒 = 整数 ÷ 1000 % 60
  40. 分 = 整数 ÷ 60000 % 60
  41. 时 = 整数 ÷ 3600000 % 24
  42. 星期 = 整数 ÷ 86400000 % 7
  43. 返回 (真)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则