设为首页收藏本站帮助中心
查看: 352|回复: 0
收起左侧

易语言MASM置入代码实现取两个整数型的平均值 相加后并除除以2(右移1位)(返回整数型)

[复制链接]
发表于 2020-6-4 17:56:29 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. 信息框 (求平均值 (111111111, 222222222), 0, , )


  8. .子程序 求平均值, 整数型, 公开, 返回=(A+B)/2
  9. .参数 A, 整数型
  10. .参数 B, 整数型

  11. 置入代码 ({ 139, 69, 8, 3, 69, 12, 209, 232, 201, 194, 8, 0 })
  12. ' mov eax,[ebp+8]
  13. ' add eax,[ebp+12]
  14. ' shr eax,1
  15. ' leave
  16. ' retn 8

  17. 返回 (0)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则