设为首页收藏本站帮助中心
查看: 388|回复: 2
收起左侧

易语言交换日期时间型的分钟与秒 (12分34秒转换到34分12秒 其他不变 返回日期时间型)

[复制链接]
发表于 2020-6-19 23:37:40 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 时间, 日期时间型

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. 时间 = 取现行时间 ()
  11. 调试输出 (时间, 日期时间型_交换分钟与秒 (时间))

  12. .子程序 日期时间型_交换分钟与秒, 日期时间型, 公开, 交换分钟与秒 12分34秒转换到34分12秒 年、月、日、时、星期 保持不变
  13. .参数 日期时间型, 日期时间型

  14. 返回 (指定时间 (取年份 (日期时间型), 取月份 (日期时间型), 取日 (日期时间型), 取小时 (日期时间型), 取秒 (日期时间型), 取分钟 (日期时间型)))

复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

发表于 2020-6-21 23:57:40 | 显示全部楼层
朵朵 发表于 2020-6-20 18:06
这是啥程序上面用的

不知道,lz很爱发这种水贴
这个小可爱很神秘,什么都没留下
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则