设为首页收藏本站帮助中心
查看: 274|回复: 0
收起左侧

易语言实现检测一个日期时间型的数据变量是否有效合法正确 (返回逻辑型)

[复制链接]
发表于 2020-6-24 23:43:43 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 A, 日期时间型
  8. .局部变量 B, 日期时间型

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. A = 取现行时间 ()

  11. 输出调试文本 (日期时间型_是否有效 (A))
  12. 输出调试文本 (日期时间型_是否有效 (B))
  13. B = 取字节集数据 ({ 1, 2, 3, 4, 5, 6, 7, 8 }, #日期时间型, )

  14. 输出调试文本 (日期时间型_是否有效 (B))


  15. .子程序 日期时间型_是否有效, 逻辑型, 公开
  16. .参数 日期时间型, 日期时间型

  17. 返回 (是否运算正确 (取字节集数据 (到字节集 (日期时间型), #双精度小数型, )) 且 到时间 (到文本 (日期时间型)) = 日期时间型)





复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则