设为首页收藏本站帮助中心
查看: 1447|回复: 0
收起左侧

易语言实现检测位图数组中的所有位图的宽度或高度是否全部一致等于相同 (返回逻辑型)

[复制链接]
发表于 2020-7-7 16:32:13 | 显示全部楼层 |阅读模式
1.png

  1. .版本 2
  2. .支持库 BmpOperate

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 位图数组, 位图, , "6"

  9. 位图数组 [1].创建 (32, 123, 24, )
  10. 位图数组 [2].创建 (32, 134, 1, )
  11. 位图数组 [3].创建 (32, 235, 8, )
  12. 位图数组 [4].创建 (32, 256, 16, )
  13. 位图数组 [5].创建 (32, 9, 24, )
  14. 位图数组 [6].创建 (32, 77, 24, )
  15. 输出调试文本 (位图数组_宽或高是否一致 (位图数组, 假))  ' 宽度全部为32,返回真
  16. 位图数组 [1].创建 (1, 256, 24, )
  17. 位图数组 [2].创建 (22, 256, 1, )
  18. 位图数组 [3].创建 (333, 256, 8, )
  19. 位图数组 [4].创建 (444, 256, 16, )
  20. 位图数组 [5].创建 (55, 256, 24, )
  21. 位图数组 [6].创建 (678, 256, 24, )
  22. 输出调试文本 (位图数组_宽或高是否一致 (位图数组, 真))  ' 高度全部为256,返回真


  23. .子程序 位图数组_宽或高是否一致, 逻辑型, 公开, 位图数组中所有位图的宽度或高度全部相同则返回真,否则返回假
  24. .参数 位图数组, 位图, 数组
  25. .参数 宽高, 逻辑型, 可空, 假为检测宽度,真为检测高度
  26. .局部变量 成员数, 整数型
  27. .局部变量 首图宽高, 整数型
  28. .局部变量 计数, 整数型

  29. 成员数 = 取数组成员数 (位图数组)
  30. .判断开始 (成员数 ≤ 0)
  31.     返回 (假)
  32. .判断 (成员数 = 1)
  33.     返回 (真)
  34. .默认

  35. .判断结束
  36. .如果 (宽高)
  37.     首图宽高 = 位图数组 [1].取高度 ()
  38. .否则
  39.     首图宽高 = 位图数组 [1].取宽度 ()
  40. .如果结束
  41. .如果真 (首图宽高 ≤ 0)
  42.     返回 (假)
  43. .如果真结束
  44. .如果 (宽高)
  45.     .变量循环首 (2, 成员数, 1, 计数)
  46.         .如果真 (位图数组 [成员数].取高度 () ≠ 首图宽高)
  47.             返回 (假)
  48.         .如果真结束

  49.     .变量循环尾 ()
  50. .否则
  51.     .变量循环首 (2, 成员数, 1, 计数)
  52.         .如果真 (位图数组 [成员数].取宽度 () ≠ 首图宽高)
  53.             返回 (假)
  54.         .如果真结束

  55.     .变量循环尾 ()
  56. .如果结束
  57. 返回 (真)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则