设为首页收藏本站帮助中心
查看: 325|回复: 0
收起左侧

易语言实现检测位图数组中是否有使用颜色表的位图 (找到返回整数型索引,未找到返回0)

[复制链接]
发表于 2020-7-10 23:58:16 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
本帖最后由 CNWTEPRG 于 2020-7-10 23:59 编辑

1.png

  1. .版本 2
  2. .支持库 BmpOperate
  3. .支持库 spec

  4. .程序集 程序集1

  5. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  6. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  7. 返回 (0)  ' 可以根据您的需要返回任意数值

  8. .子程序 _临时子程序
  9. .局部变量 位图, 位图, , "3"

  10. 位图 [1].创建 (32, 32, 24, #黑色)
  11. 位图 [2].创建 (32, 32, 24, #黑色)
  12. 位图 [3].创建 (32, 32, 8, #黑色)
  13. 调试输出 (位图数组_取使用颜色表的位图 (位图))



  14. .子程序 位图数组_取使用颜色表的位图, 整数型, 公开, 找到返回数组索引,未找到返回0
  15. .参数 数组, 位图, 数组
  16. .局部变量 计数, 整数型

  17. .计次循环首 (取数组成员数 (数组), 计数)
  18.     .如果真 (数组 [计数].是否使用颜色表 ())
  19.         返回 (计数)
  20.     .如果真结束

  21. .计次循环尾 ()
  22. 返回 (0)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则