设为首页收藏本站帮助中心
查看: 219|回复: 1
收起左侧

易语言实现求被除数最大可以被整除的除数 (返回除数 整数型)

[复制链接]
发表于 2020-7-30 23:15:52 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
11.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 除数, 整数型

  8. 信息框 (求最大可被整除的除数 (1000000, 65535), 0, , )

  9. .子程序 求最大可被整除的除数, 整数型, 公开, 返回除数
  10. .参数 被除数, 整数型
  11. .参数 除数最大值, 整数型, 可空
  12. .局部变量 除数, 整数型
  13. .局部变量 返回值, 整数型

  14. .计次循环首 (被除数, 除数)
  15.     .如果真 (被除数 % 除数 = 0)
  16.         .如果真 (除数 > 返回值)
  17.             返回值 = 除数
  18.         .如果真结束

  19.     .如果真结束
  20.     .如果真 (除数 > 除数最大值 且 除数最大值 > 0)
  21.         跳出循环 ()
  22.     .如果真结束

  23. .计次循环尾 ()
  24. 返回 (返回值)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则