设为首页收藏本站帮助中心
查看: 160|回复: 0
收起左侧

易语言MASM置入代码实现取文本型字符串的第1字节是否为半角数字0~9开头 (返回逻辑型)

[复制链接]
发表于 2020-8-13 16:50:36 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (文本型_第1字节是否为数字 (“123”))
  9. 输出调试文本 (文本型_第1字节是否为数字 (“1a2b3c”))
  10. 输出调试文本 (文本型_第1字节是否为数字 (“a1b2c3”))


  11. .子程序 文本型_第1字节是否为数字, 逻辑型, 公开
  12. .参数 字符串, 文本型

  13. 置入代码 ({ 139, 69, 8, 11, 192, 117, 2, 235, 27, 139, 0, 11, 192, 117, 2, 235, 19, 138, 0, 60, 48, 114, 11, 60, 57, 119, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 4, 0 })
  14. ' mov eax,[ebp+8]
  15. ' .if !eax
  16. ' jmp ASM_END
  17. ' .endif
  18. ' mov eax,[eax]
  19. ' .if !eax
  20. ' jmp ASM_END
  21. ' .endif
  22. ' mov al,[eax]
  23. ' .if al >= 48 && al <= 57
  24. ' mov eax,1
  25. ' .else
  26. ' xor eax,eax
  27. ' .endif
  28. ' ASM_END:
  29. ' leave
  30. ' retn 4
  31. 返回 (假)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则