设为首页收藏本站帮助中心
查看: 160|回复: 0
收起左侧

易语言MASM汇编置入代码实现取指针的文本型长度 (返回整数型)

[复制链接]
发表于 2020-8-17 20:53:34 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 文本, 文本型
  9. .局部变量 指针, 整数型

  10. 文本 = “Hello World! 中文测试”
  11. 指针 = 取变量数据地址 (文本)
  12. 输出调试文本 (指针取文本长度 (指针), 取文本长度 (文本))


  13. .子程序 指针取文本长度, 整数型, 公开, 汇编版:返回 (取文本长度 (指针到文本 (指针)))
  14. .参数 内存文本指针, 整数型

  15. 置入代码 ({ 83, 81, 139, 69, 8, 139, 216, 138, 8, 10, 201, 117, 2, 235, 3, 64, 235, 245, 43, 195, 89, 91, 201, 194, 4, 0 })
  16. ' push ebx
  17. ' push ecx
  18. ' mov eax,[ebp+8]
  19. ' mov ebx,eax
  20. ' .while 1
  21. ' mov cl,[eax]
  22. ' .if !cl
  23. ' .break
  24. ' .endif
  25. ' inc eax
  26. ' .endw
  27. ' sub eax,ebx
  28. ' pop ecx
  29. ' pop ebx
  30. ' ASM_END:
  31. ' leave
  32. ' retn 4

  33. 返回 (0)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则