设为首页收藏本站帮助中心
查看: 179|回复: 0
收起左侧

易语言MASM汇编置入代码实现检测文本型字符串中是否包含半角数字0~9 (返回逻辑型)

[复制链接]
发表于 2020-8-23 18:08:06 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (文本型_是否包含数字 (“abc123”))
  9. 输出调试文本 (文本型_是否包含数字 (“Abcdef”))
  10. 输出调试文本 (文本型_是否包含数字 (“中文”))
  11. 输出调试文本 (文本型_是否包含数字 (“666”))
  12. 输出调试文本 (文本型_是否包含数字 (“!@#”))
  13. 输出调试文本 (文本型_是否包含数字 (“”))

  14. .子程序 文本型_是否包含数字, 逻辑型, 公开, 空文本返回假
  15. .参数 文本, 文本型

  16. 置入代码 ({ 139, 69, 8, 11, 192, 117, 2, 235, 40, 139, 0, 11, 192, 117, 2, 235, 32, 138, 8, 10, 201, 117, 6, 51, 192, 235, 22, 235, 17, 128, 249, 48, 114, 12, 128, 249, 57, 119, 7, 184, 1, 0, 0, 0, 235, 3, 64, 235, 224, 201, 194, 4, 0 })
  17. ' mov eax,[ebp+8]
  18. ' .if !eax
  19. ' jmp ASM_END
  20. ' .endif
  21. ' mov eax,[eax]
  22. ' .if !eax
  23. ' jmp ASM_END
  24. ' .endif
  25. ' .while 1
  26. ' mov cl,[eax]
  27. ' .if !cl
  28. ' xor eax,eax
  29. ' .break
  30. ' .elseif cl >= 48 && cl <= 57
  31. ' mov eax,1
  32. ' .break
  33. ' .endif
  34. ' inc eax
  35. ' .endw
  36. ' ASM_END:
  37. ' leave
  38. ' retn 4

  39. 返回 (假)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则