设为首页收藏本站帮助中心
查看: 215|回复: 0
收起左侧

易语言MASM置入代码实现获取字节集长度(字节型数组成员数)是否为奇偶数(返回逻辑型)

[复制链接]
发表于 2020-8-27 23:22:23 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 字节集, 字节集
  8. .局部变量 数组, 字节型, , "0"

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. 字节集 = { 1, 2, 3, 4, 5 }
  11. 输出调试文本 (字节集长度_是否为奇数 (字节集))
  12. 字节集 = { 1, 2 }
  13. 输出调试文本 (字节集长度_是否为偶数 (字节集))
  14. 数组 = { 1, 2, 3, 4, 5 }
  15. 输出调试文本 (字节型数组_成员数是否为奇数 (数组))
  16. 数组 = { 1, 2, 3, 4 }
  17. 输出调试文本 (字节型数组_成员数是否为偶数 (数组))


  18. .子程序 字节集长度_是否为奇数, 逻辑型, 公开, 返回 (位与 (取字节集长度 (字节集), 1) = 1)
  19. .参数 字节集, 字节集

  20. 置入代码 ({ 11, 192, 117, 2, 235, 14, 139, 0, 11, 192, 117, 2, 235, 6, 139, 64, 4, 131, 224, 1, 201, 194, 4, 0 })
  21. ' .if !eax
  22. ' jmp ASM_END
  23. ' .endif
  24. ' mov eax,[eax]
  25. ' .if !eax
  26. ' jmp ASM_END
  27. ' .endif
  28. ' mov eax,[eax+4]
  29. ' and eax,1
  30. ' ASM_END:
  31. ' leave
  32. ' retn 4
  33. 返回 (假)

  34. .子程序 字节集长度_是否为偶数, 逻辑型, 公开, 返回 (位与 (取字节集长度 (字节集), 1) = 0)
  35. .参数 字节集, 字节集

  36. 置入代码 ({ 11, 192, 117, 2, 235, 14, 139, 0, 11, 192, 117, 2, 235, 6, 139, 64, 4, 131, 224, 1, 131, 240, 1, 201, 194, 4, 0 })
  37. ' .if !eax
  38. ' jmp ASM_END
  39. ' .endif
  40. ' mov eax,[eax]
  41. ' .if !eax
  42. ' jmp ASM_END
  43. ' .endif
  44. ' mov eax,[eax+4]
  45. ' and eax,1
  46. ' ASM_END:
  47. ' xor eax,1
  48. ' leave
  49. ' retn 4
  50. 返回 (假)

  51. .子程序 字节型数组_成员数是否为奇数, 逻辑型, 公开, 返回 (位与 (取数组成员数 (数组), 1) = 1)
  52. .参数 数组, 字节型, 数组

  53. 置入代码 ({ 11, 192, 117, 2, 235, 14, 139, 0, 11, 192, 117, 2, 235, 6, 139, 64, 4, 131, 224, 1, 201, 194, 4, 0 })
  54. ' .if !eax
  55. ' jmp ASM_END
  56. ' .endif
  57. ' mov eax,[eax]
  58. ' .if !eax
  59. ' jmp ASM_END
  60. ' .endif
  61. ' mov eax,[eax+4]
  62. ' and eax,1
  63. ' ASM_END:
  64. ' leave
  65. ' retn 4
  66. 返回 (假)

  67. .子程序 字节型数组_成员数是否为偶数, 逻辑型, 公开, 返回 (位与 (取数组成员数 (数组), 1) = 0)
  68. .参数 数组, 字节型, 数组

  69. 置入代码 ({ 11, 192, 117, 2, 235, 14, 139, 0, 11, 192, 117, 2, 235, 6, 139, 64, 4, 131, 224, 1, 131, 240, 1, 201, 194, 4, 0 })
  70. ' .if !eax
  71. ' jmp ASM_END
  72. ' .endif
  73. ' mov eax,[eax]
  74. ' .if !eax
  75. ' jmp ASM_END
  76. ' .endif
  77. ' mov eax,[eax+4]
  78. ' and eax,1
  79. ' ASM_END:
  80. ' xor eax,1
  81. ' leave
  82. ' retn 4
  83. 返回 (假)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则