设为首页收藏本站帮助中心
查看: 203|回复: 0
收起左侧

易语言MASM置入代码将子程序指针/小数型/长整数型转换到逻辑型 (0返回假,非0返回真)

[复制链接]
发表于 2020-8-30 19:46:56 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 指针, 子程序指针

  9. 输出调试文本 (到逻辑_子程序指针 (指针))
  10. 指针 = &到逻辑_子程序指针
  11. 输出调试文本 (到逻辑_子程序指针 (指针))
  12. 调试输出 (到逻辑_小数型 (0), 到逻辑_小数型 (1.1), 到逻辑_小数型 (-1.23))
  13. 调试输出 (到逻辑_长整数型 (0), 到逻辑_长整数型 (-1), 到逻辑_长整数型 (2))

  14. .子程序 到逻辑_子程序指针, 逻辑型, 公开, 0返回假,非0返回真
  15. .参数 值, 子程序指针

  16. 置入代码 ({ 139, 69, 8, 11, 192, 116, 7, 184, 1, 0, 0, 0, 235, 0, 201, 194, 4, 0 })
  17. ' mov eax,[ebp+8]
  18. ' .if eax
  19. ' mov eax,1
  20. ' .else
  21. ' .endif
  22. ' leave
  23. ' retn 4
  24. 返回 (假)

  25. .子程序 到逻辑_小数型, 逻辑型, 公开, 0返回假,非0返回真
  26. .参数 值, 小数型

  27. 置入代码 ({ 139, 69, 8, 11, 192, 116, 7, 184, 1, 0, 0, 0, 235, 0, 201, 194, 4, 0 })
  28. ' mov eax,[ebp+8]
  29. ' .if eax
  30. ' mov eax,1
  31. ' .else
  32. ' .endif
  33. ' leave
  34. ' retn 4
  35. 返回 (假)

  36. .子程序 到逻辑_长整数型, 逻辑型, 公开, 0返回假,非0返回真
  37. .参数 值, 长整数型

  38. 置入代码 ({ 82, 139, 69, 8, 139, 85, 12, 11, 192, 117, 4, 11, 210, 116, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 90, 201, 194, 8, 0 })
  39. ' push edx
  40. ' mov eax,[ebp+8]
  41. ' mov edx,[ebp+12]
  42. ' .if eax || edx
  43. ' mov eax,1
  44. ' .elseif
  45. ' xor eax,eax
  46. ' .endif
  47. ' pop edx
  48. ' leave
  49. ' retn 8
  50. 返回 (假)

复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则