设为首页收藏本站帮助中心
查看: 245|回复: 0
收起左侧

易语言MASM置入代码实现将字节型/短整数型/整数型的逻辑取反 (0返回真,非0返回假)

[复制链接]
发表于 2020-9-1 23:03:00 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 调试输出 (逻辑取反_字节型 (0), 逻辑取反_字节型 (1), 逻辑取反_字节型 (-2))
  10. 调试输出 (逻辑取反_短整数型 (0), 逻辑取反_短整数型 (1), 逻辑取反_短整数型 (-2))
  11. 调试输出 (逻辑取反_整数型 (0), 逻辑取反_整数型 (1), 逻辑取反_整数型 (-2))



  12. .子程序 逻辑取反_字节型, 逻辑型, 公开, 0返回真,非0返回假
  13. .参数 值, 字节型

  14. 置入代码 ({ 138, 69, 8, 10, 192, 116, 4, 51, 192, 235, 5, 184, 1, 0, 0, 0, 201, 194, 4, 0 })
  15. ' mov al,[ebp+8]
  16. ' .if al
  17. ' xor eax,eax
  18. ' .else
  19. ' mov eax,1
  20. ' .endif
  21. ' leave
  22. ' retn 4

  23. 返回 (假)

  24. .子程序 逻辑取反_短整数型, 逻辑型, 公开, 0返回真,非0返回假
  25. .参数 值, 短整数型

  26. 置入代码 ({ 102, 139, 69, 8, 102, 11, 192, 116, 4, 51, 192, 235, 5, 184, 1, 0, 0, 0, 201, 194, 4, 0 })
  27. ' mov ax,[ebp+8]
  28. ' .if ax
  29. ' xor eax,eax
  30. ' .else
  31. ' mov eax,1
  32. ' .endif
  33. ' leave
  34. ' retn 4

  35. 返回 (假)

  36. .子程序 逻辑取反_整数型, 逻辑型, 公开, 0返回真,非0返回假
  37. .参数 值, 整数型

  38. 置入代码 ({ 139, 69, 8, 11, 192, 116, 5, 184, 1, 0, 0, 0, 131, 240, 1, 201, 194, 4, 0 })
  39. ' mov eax,[ebp+8]
  40. ' .if eax
  41. ' mov eax,1
  42. ' .endif
  43. ' xor eax,1
  44. ' leave
  45. ' retn 4

  46. 返回 (假)

复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则