设为首页收藏本站帮助中心
查看: 215|回复: 0
收起左侧

易语言MASM置入代码实现将双精度小数型/日期时间型的逻辑取反 (返回逻辑型)

[复制链接]
发表于 2020-9-3 22:48:34 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 调试输出 (逻辑取反_双精度小数型 (0), 逻辑取反_双精度小数型 (0.1), 逻辑取反_双精度小数型 (-0.2))
  10. 调试输出 (逻辑取反_日期时间型 ([1899年12月30日]), 逻辑取反_日期时间型 (取现行时间 ()), 逻辑取反_日期时间型 ([2020年1月1日]))



  11. .子程序 逻辑取反_双精度小数型, 逻辑型, 公开, 0返回真,非0返回假
  12. .参数 值, 双精度小数型

  13. 置入代码 ({ 82, 139, 69, 8, 139, 85, 12, 11, 192, 117, 4, 11, 210, 116, 4, 51, 192, 235, 5, 184, 1, 0, 0, 0, 90, 201, 194, 8, 0 })
  14. ' push edx
  15. ' mov eax,[ebp+8]
  16. ' mov edx,[ebp+12]
  17. ' .if eax || edx
  18. ' xor eax,eax
  19. ' .elseif
  20. ' mov eax,1
  21. ' .endif
  22. ' pop edx
  23. ' leave
  24. ' retn 8

  25. 返回 (假)

  26. .子程序 逻辑取反_日期时间型, 逻辑型, 公开, 1899年12月30日返回真,否则返回假
  27. .参数 值, 日期时间型

  28. 置入代码 ({ 82, 139, 69, 8, 139, 85, 12, 11, 192, 117, 4, 11, 210, 116, 4, 51, 192, 235, 5, 184, 1, 0, 0, 0, 90, 201, 194, 8, 0 })
  29. ' push edx
  30. ' mov eax,[ebp+8]
  31. ' mov edx,[ebp+12]
  32. ' .if eax || edx
  33. ' xor eax,eax
  34. ' .elseif
  35. ' mov eax,1
  36. ' .endif
  37. ' pop edx
  38. ' leave
  39. ' retn 8

  40. 返回 (假)


复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则