设为首页收藏本站帮助中心
查看: 261|回复: 0
收起左侧

易语言MASM置入代码实现检测日期时间型变量是否大于等于1899年12月30日 (返回逻辑型)

[复制链接]
发表于 2020-9-4 23:37:56 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. 输出调试文本 (日期时间型_是否大于等于1899年12月30日 ([1899年12月30日]))
  8. 输出调试文本 (日期时间型_是否大于等于1899年12月30日 ([100年1月1日]))
  9. 输出调试文本 (日期时间型_是否大于等于1899年12月30日 ([6666年6月6日]))
  10. 输出调试文本 (日期时间型_是否大于等于1899年12月30日 ([1899年12月29日23时59分59秒]))输出调试文本 (日期时间型_是否大于等于1899年12月30日 (取现行时间 ()))

  11. .子程序 日期时间型_是否大于等于1899年12月30日, 逻辑型, 公开
  12. .参数 值, 日期时间型

  13. 置入代码 ({ 139, 69, 12, 37, 0, 0, 0, 128, 11, 192, 116, 4, 51, 192, 235, 5, 184, 1, 0, 0, 0, 201, 194, 8, 0 })
  14. ' mov eax,[ebp+12]
  15. ' and eax,80000000H
  16. ' .if eax
  17. ' xor eax,eax
  18. ' .else
  19. ' mov eax,1
  20. ' .endif
  21. ' leave
  22. ' retn 8

  23. 返回 (假)

复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则