设为首页收藏本站帮助中心
查看: 275|回复: 0
收起左侧

易语言MASM置入代码实现检测长整数型/双精度小数型是否大于等于0 (返回逻辑型)

[复制链接]
发表于 2020-9-5 23:22:39 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 调试输出 (长整数型_是否大于等于零 (-1), 长整数型_是否大于等于零 (0), 长整数型_是否大于等于零 (100))
  10. 调试输出 (双精度小数型_是否大于等于零 (-1.1), 双精度小数型_是否大于等于零 (0), 双精度小数型_是否大于等于零 (123.456))



  11. .子程序 长整数型_是否大于等于零, 逻辑型, 公开
  12. .参数 值, 长整数型

  13. 置入代码 ({ 139, 69, 12, 37, 0, 0, 0, 128, 11, 192, 116, 4, 51, 192, 235, 5, 184, 1, 0, 0, 0, 201, 194, 8, 0 })
  14. ' mov eax,[ebp+12]
  15. ' and eax,80000000H
  16. ' .if eax
  17. ' xor eax,eax
  18. ' .else
  19. ' mov eax,1
  20. ' .endif
  21. ' leave
  22. ' retn 8

  23. 返回 (假)

  24. .子程序 双精度小数型_是否大于等于零, 逻辑型, 公开
  25. .参数 值, 双精度小数型

  26. 置入代码 ({ 139, 69, 12, 37, 0, 0, 0, 128, 11, 192, 116, 4, 51, 192, 235, 5, 184, 1, 0, 0, 0, 201, 194, 8, 0 })
  27. ' mov eax,[ebp+12]
  28. ' and eax,80000000H
  29. ' .if eax
  30. ' xor eax,eax
  31. ' .else
  32. ' mov eax,1
  33. ' .endif
  34. ' leave
  35. ' retn 8

  36. 返回 (假)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则