设为首页收藏本站帮助中心
查看: 47|回复: 0
收起左侧

易语言MASM置入代码实现将文本型字符串所有的TAB制表符替换为空格 (无返回值)

[复制链接]
发表于 2020-9-8 21:59:29 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
本帖最后由 EAX 于 2020-9-8 21:59 编辑

1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 文本型, 文本型

  8. 文本型 = “1” + 字符 (9) + “2 3”
  9. 输出调试文本 (文本型)
  10. 文本型_TAB替换为空格 (文本型)
  11. 输出调试文本 (文本型)



  12. .子程序 文本型_TAB替换为空格, , 公开
  13. .参数 文本型变量, 文本型, 参考

  14. 置入代码 ({ 80, 81, 139, 69, 8, 11, 192, 117, 2, 235, 30, 139, 0, 11, 192, 117, 2, 235, 22, 138, 8, 10, 201, 117, 4, 235, 14, 235, 9, 128, 249, 9, 117, 4, 177, 32, 136, 8, 64, 235, 234, 89, 88 })
  15. ' push eax
  16. ' push ecx
  17. ' mov eax,[ebp+8]
  18. ' .if !eax
  19. ' jmp ASM_END
  20. ' .endif
  21. ' mov eax,[eax]
  22. ' .if !eax
  23. ' jmp ASM_END
  24. ' .endif
  25. ' .while 1
  26. ' mov cl,[eax]
  27. ' .if !cl
  28. ' .break
  29. ' .elseif cl == 9
  30. ' mov cl,32
  31. ' mov [eax],cl
  32. ' .endif
  33. ' inc eax
  34. ' .endw
  35. ' ASM_END:
  36. ' pop ecx
  37. ' pop eax

复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则