设为首页收藏本站帮助中心
查看: 280|回复: 0
收起左侧

易语言MASM置入代码实现交换替换文本型字符串中的两个指定字节 (无返回值)

[复制链接]
发表于 2020-9-9 23:45:36 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
11.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 A, 文本型

  9. A = “ABABAABB123AABBaabb”
  10. 文本型_交换字节 (A, 取代码 (“A”, ), 取代码 (“B”, ))  ' 字符串中的A变B,B变A
  11. 调试输出 (A)

  12. .子程序 文本型_交换字节, , 公开
  13. .参数 文本型变量, 文本型, 参考
  14. .参数 被交换字节, 字节型, , 区分大小写,不能为0,不能与 交换字节 相同
  15. .参数 交换字节, 字节型

  16. 置入代码 ({ 80, 81, 82, 139, 69, 8, 11, 192, 117, 2, 235, 55, 139, 0, 11, 192, 117, 2, 235, 47, 138, 85, 12, 138, 117, 16, 56, 242, 116, 8, 10, 210, 116, 4, 10, 246, 117, 2, 235, 27, 138, 8, 10, 201, 117, 4, 235, 19, 235, 14, 56, 209, 117, 4, 136, 48, 235, 6, 56, 241, 117, 2, 136, 16, 64, 235, 229, 90, 89, 88 })
  17. ' push eax
  18. ' push ecx
  19. ' push edx
  20. ' mov eax,[ebp+8]
  21. ' .if !eax
  22. ' jmp ASM_END
  23. ' .endif
  24. ' mov eax,[eax]
  25. ' .if !eax
  26. ' jmp ASM_END
  27. ' .endif
  28. ' mov dl,[ebp+12]
  29. ' mov dh,[ebp+16]
  30. ' .if dl == dh || !dl || !dh
  31. ' jmp ASM_END
  32. ' .endif
  33. ' .while 1
  34. ' mov cl,[eax]
  35. ' .if !cl
  36. ' .break
  37. ' .elseif cl == dl
  38. ' mov [eax],dh
  39. ' .elseif cl == dh
  40. ' mov [eax],dl
  41. ' .endif
  42. ' inc eax
  43. ' .endw
  44. ' ASM_END:
  45. ' pop edx
  46. ' pop ecx
  47. ' pop eax

复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则