设为首页收藏本站帮助中心
查看: 21|回复: 0
收起左侧

易语言MASM置入代码实现检测整数型高低16位是否相同等于一致 (返回逻辑型)

[复制链接]
发表于 6 天前 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型


  4. _临时子程序 ()
  5. 返回 (0)

  6. .子程序 _临时子程序

  7. 输出调试文本 (整数型_高低16位是否相同 (0))
  8. 输出调试文本 (整数型_高低16位是否相同 (-1))
  9. 输出调试文本 (整数型_高低16位是否相同 (2882382797))
  10. 输出调试文本 (整数型_高低16位是否相同 (858993459))
  11. 输出调试文本 (整数型_高低16位是否相同 (858993459))
  12. 输出调试文本 (整数型_高低16位是否相同 (1297763674))
  13. 输出调试文本 (整数型_高低16位是否相同 (3435973836))
  14. 输出调试文本 (整数型_高低16位是否相同 (4278124286))
  15. 输出调试文本 (整数型_高低16位是否相同 (1234567890))


  16. .子程序 整数型_高低16位是否相同, 逻辑型, 公开
  17. .参数 值, 整数型

  18. 置入代码 ({ 102, 139, 69, 8, 102, 59, 69, 10, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 4, 0 })
  19. ' mov ax,[ebp+8]
  20. ' .if ax == [ebp+10]
  21. ' mov eax,1
  22. ' .else
  23. ' xor eax,eax
  24. ' .endif
  25. ' leave
  26. ' retn 4
  27. 返回 (假)
复制代码


相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则