设为首页收藏本站帮助中心
查看: 261|回复: 0
收起左侧

易语言MASM置入代码实现检测字节型高低4位半字节是否相同等于一致 (返回逻辑型)

[复制链接]
发表于 2020-9-14 22:31:56 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 i, 整数型
  9. .局部变量 j, 整数型, , "0"

  10. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  11. .变量循环首 (0, 255, 1, i)
  12.     .如果真 (字节型_高低4位是否一致 (i))
  13.         加入成员 (j, i)
  14.     .如果真结束

  15. .变量循环尾 ()
  16. 调试输出 (j)

  17. .子程序 字节型_高低4位是否一致, 逻辑型, 公开, 0,17,34,51,68,85,102,119,136,153,170,187,204,221,238,255 返回真,其余返回假
  18. .参数 字节, 字节型

  19. 置入代码 ({ 138, 69, 8, 138, 224, 192, 200, 4, 56, 196, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 4, 0 })
  20. ' mov al,[ebp+8]
  21. ' mov ah,al
  22. ' ror al,4
  23. ' .if ah == al
  24. ' mov eax,1
  25. ' .elseif
  26. ' xor eax,eax
  27. ' .endif
  28. ' leave
  29. ' retn 4
  30. 返回 (假)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则