设为首页收藏本站帮助中心
查看: 247|回复: 0
收起左侧

易语言MASM置入代码实现检测判断比较长整数型高低32位是否相同等于一致 (返回逻辑型)

[复制链接]
发表于 2020-9-15 16:33:09 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (长整数型_高低32位是否相同 (-1))
  9. 输出调试文本 (长整数型_高低32位是否相同 (0))
  10. 输出调试文本 (长整数型_高低32位是否相同 (到长整数 (“289077004467372545”)))
  11. 输出调试文本 (长整数型_高低32位是否相同 (12345))


  12. .子程序 长整数型_高低32位是否相同, 逻辑型, 公开
  13. .参数 值, 长整数型

  14. 置入代码 ({ 139, 69, 8, 59, 69, 12, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  15. ' mov eax,[ebp+8]
  16. ' .if eax == [ebp+12]
  17. ' mov eax,1
  18. ' .else
  19. ' xor eax,eax
  20. ' .endif
  21. ' leave
  22. ' retn 8
  23. 返回 (假)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则