设为首页收藏本站帮助中心
查看: 235|回复: 0
收起左侧

易语言MASM置入代码实现两个短整数型高低双8位不带进位独立加法计算 (返回短整数型)

[复制链接]
发表于 2020-9-16 19:42:36 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 A, 短整数型
  9. .局部变量 B, 短整数型

  10. A = 取字节集数据 ({ 78, 48 }, #短整数型, )
  11. B = 取字节集数据 ({ 232, 26 }, #短整数型, )


  12. 调试输出 (到字节集 (短整数型_双8位无进位相加 (A, B)), 到字节集 (到短整数 (A + B)))  ' 78+232=54 48+26=74

  13. .子程序 短整数型_双8位无进位相加, 短整数型, 公开, 低8位相加产生的进位将被丢弃,不会给高8位
  14. .参数 被加数, 短整数型
  15. .参数 加数, 短整数型

  16. 置入代码 ({ 138, 69, 8, 2, 69, 12, 138, 101, 9, 2, 101, 13, 37, 255, 255, 0, 0, 201, 194, 8, 0 })
  17. ' mov al,[ebp+8]
  18. ' add al,[ebp+12]
  19. ' mov ah,[ebp+9]
  20. ' add ah,[ebp+13]
  21. ' and eax,65535
  22. ' leave
  23. ' retn 8
  24. 返回 (0)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则