设为首页收藏本站帮助中心
查看: 1110|回复: 0
收起左侧

易语言MASM置入代码已知长方形的长宽计算出周长 支持负数计算 (返回整数型)

[复制链接]
发表于 2020-9-18 21:56:44 | 显示全部楼层 |阅读模式

孩子辍学不想上学打工咋办?
来我这免费学:易语言、51单片机、FPGA(IC设计)、PHP Dsicuz! 程序修改、MASM汇编,包教包会,学废为止。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (整数型_长方形已知长宽求周长 (12345, 67890), (12345 + 67890) × 2)
  9. 输出调试文本 (整数型_长方形已知长宽求周长 (-123, 456), (-123 + 456) × 2)


  10. .子程序 整数型_长方形已知长宽求周长, 整数型, 公开
  11. .参数 长, 整数型
  12. .参数 宽, 整数型

  13. 置入代码 ({ 139, 69, 8, 3, 69, 12, 209, 224, 201, 194, 8, 0 })
  14. ' mov eax,[ebp+8]
  15. ' add eax,[ebp+12]
  16. ' shl eax,1
  17. ' leave
  18. ' retn 8
  19. 返回 (0)
复制代码

相关帖子

本站源码使用前请注意检查,如有问题请点击右下角举报,将在24小时内得到答复。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则