设为首页收藏本站帮助中心
查看: 127|回复: 0
收起左侧

易语言MASM汇编置入代码实现字节型的半字节交换 相当于C51的[SWAP A]指令(返回字节型)

[复制链接]
发表于 2020-9-20 21:58:29 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (半字节交换 (123))
  9. 输出调试文本 (半字节交换 (183))
  10. 输出调试文本 (半字节交换 (1))
  11. 输出调试文本 (半字节交换 (170))
  12. 输出调试文本 (半字节交换 (234))


  13. .子程序 半字节交换, 字节型, 公开, 输入:0x7B(123) 返回:0xB7(183)
  14. .参数 值, 字节型

  15. 置入代码 ({ 138, 69, 8, 192, 200, 4, 37, 255, 0, 0, 0, 201, 194, 4, 0 })
  16. ' mov al,[ebp+8]
  17. ' ror al,4
  18. ' and eax,255
  19. ' leave
  20. ' retn 4
  21. 返回 (0)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则