设为首页收藏本站帮助中心
查看: 165|回复: 1
收起左侧

易语言实现使用系统自带画图软件 mspaint 打开《位图》数据类型 (返回逻辑型)

[复制链接]
发表于 2020-10-22 19:54:53 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
本帖最后由 CNWTEPRG 于 2020-10-22 19:54 编辑

@@@.png

  1. .版本 2
  2. .支持库 BmpOperate

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 位图, 位图

  9. 位图.创建 (256, 256, 24, #紫色)
  10. 检查 (位图_画图打开 (位图))

  11. .子程序 位图_画图打开, 逻辑型, 公开, 使用系统自带画图软件 mspaint 打开位图,成功返回真失败返回假
  12. .参数 位图, 位图
  13. .局部变量 数据, 字节集
  14. .局部变量 临时文件名, 文本型

  15. 数据 = 位图.取位图数据 ()
  16. 临时文件名 = 取临时文件名 ()
  17. .判断开始 (数据 = {  })
  18.     返回 (假)
  19. .判断 (写到文件 (临时文件名, 数据) = 假)
  20.     返回 (假)
  21. .判断 (运行 (“mspaint ” + #引号 + 临时文件名 + #引号, 假, ) = 假)
  22.     返回 (假)
  23. .默认

  24. .判断结束
  25. 返回 (真)

复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则