设为首页收藏本站帮助中心
查看: 956|回复: 1
收起左侧

易语言实现判断文本型数组文件名中的所有文件是否全部存在 (返回逻辑型)

[复制链接]
发表于 2020-11-1 17:50:22 | 显示全部楼层 |阅读模式

孩子辍学不想上学打工咋办?
来我这免费学:易语言、51单片机、FPGA(IC设计)、PHP Dsicuz! 程序修改、MASM汇编,包教包会,学废为止。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 信息框 (文件是否存在_数组 ({ “C:\1.TXT”, “D:\2.TXT”, “E:\3.TXT” }), 0, , )


  9. .子程序 文件是否存在_数组, 逻辑型, 公开, 一个文件不存在,返回假,全部存在返回真
  10. .参数 欲测试的文件名称数组, 文本型, 数组
  11. .局部变量 成员数, 整数型
  12. .局部变量 计数, 整数型

  13. 成员数 = 取数组成员数 (欲测试的文件名称数组)
  14. .计次循环首 (成员数, 计数)
  15.     .如果真 (文件是否存在 (欲测试的文件名称数组 [计数]) = 假)
  16.         返回 (假)
  17.     .如果真结束

  18. .计次循环尾 ()
  19. 返回 (真)
复制代码

相关帖子

本站源码使用前请注意检查,如有问题请点击右下角举报,将在24小时内得到答复。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则