设为首页收藏本站帮助中心
查看: 325|回复: 2
收起左侧

易语言全屏黑屏并在四周边框显示1像素显示RGB边框线条 (液晶屏显示器测试,安装专用)

[复制链接]
发表于 2020-11-5 08:32:36 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2
  2. .支持库 BmpOperate

  3. .程序集 窗口程序集_启动窗口
  4. .程序集变量 屏宽, 整数型
  5. .程序集变量 屏高, 整数型
  6. .程序集变量 颜色表, 整数型, , "0"
  7. .程序集变量 颜色数, 整数型
  8. .程序集变量 位图, 位图, , "0"

  9. .子程序 __启动窗口_创建完毕
  10. .局部变量 j, 整数型
  11. .局部变量 k, 整数型

  12. 颜色表 = { #红色, #绿色, #蓝色 }
  13. 颜色数 = 取数组成员数 (颜色表)
  14. 底色 = #黑色
  15. 左边 = 0
  16. 顶边 = 0
  17. 屏宽 = 取屏幕宽度 ()
  18. 屏高 = 取屏幕高度 ()
  19. 宽度 = 屏宽
  20. 高度 = 屏高
  21. Esc键关闭 = 真
  22. 总在最前 = 真
  23. 重定义数组 (位图, 假, 颜色数)
  24. .计次循环首 (颜色数, k)
  25.     位图 [k].创建 (屏宽, 屏高, 4, 底色)
  26.     .变量循环首 (0, 屏宽 - 1, 1, j)
  27.         位图 [k].置某点颜色 (j, 0, 颜色表 [k])
  28.         位图 [k].置某点颜色 (j, 屏高 - 1, 颜色表 [k])
  29.     .变量循环尾 ()
  30.     .变量循环首 (0, 屏高 - 1, 1, j)
  31.         位图 [k].置某点颜色 (0, j, 颜色表 [k])
  32.         位图 [k].置某点颜色 (屏宽 - 1, j, 颜色表 [k])
  33.     .变量循环尾 ()
  34. .计次循环尾 ()
  35. _时钟1_周期事件 ()
  36. 可视 = 真
  37. 时钟1.时钟周期 = 1000

  38. .子程序 _时钟1_周期事件
  39. .局部变量 颜色计数, 整数型, 静态

  40. 颜色计数 = 颜色计数 + 1
  41. .如果真 (颜色计数 > 颜色数)
  42.     颜色计数 = 1
  43. .如果真结束
  44. 底图 = 位图 [颜色计数].取位图数据 ()
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则