设为首页收藏本站帮助中心
查看: 42|回复: 0
收起左侧

易语言 短整数型/整数型/长整数型 三位分节法 按逗号分割数值 (支持负数,返回文本型)

[复制链接]
发表于 2021-1-6 21:02:23 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 计数, 整数型

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 输出调试文本 (短整数型_三位分节 (23456))
  10. 输出调试文本 (整数型_三位分节 (-1234567890))
  11. 输出调试文本 (长整数型_三位分节 (到长整数 (“1000000000000001”)))



  12. .子程序 短整数型_三位分节, 文本型, 公开, 输入:12345 输出 12,345 (支持负数)
  13. .参数 值, 短整数型
  14. .局部变量 负数, 逻辑型
  15. .局部变量 文本整数, 文本型
  16. .局部变量 分段, 文本型, , "0"
  17. .局部变量 计数, 整数型
  18. .局部变量 返回值, 文本型
  19. .局部变量 长度, 整数型

  20. .如果真 (值 = -32768)
  21.     返回 (“-32,768”)
  22. .如果真结束
  23. 负数 = 值 < 0
  24. .如果真 (负数)
  25.     值 = 0 - 值
  26. .如果真结束
  27. 文本整数 = 到文本 (值)
  28. 长度 = 取文本长度 (文本整数)
  29. 返回值 = 取文本左边 (文本整数, (长度 - 1) % 3 + 1) + “,”
  30. .变量循环首 (取文本长度 (返回值), 长度, 3, 计数)
  31.     返回值 = 返回值 + 取文本中间 (文本整数, 计数, 3) + “,”
  32. .变量循环尾 ()
  33. 返回 (选择 (负数, “-”, “”) + 取文本左边 (返回值, 取文本长度 (返回值) - 1))


  34. .子程序 整数型_三位分节, 文本型, 公开, 输入:12345 输出 12,345 (支持负数)
  35. .参数 值, 整数型
  36. .局部变量 负数, 逻辑型
  37. .局部变量 文本整数, 文本型
  38. .局部变量 分段, 文本型, , "0"
  39. .局部变量 计数, 整数型
  40. .局部变量 返回值, 文本型
  41. .局部变量 长度, 整数型

  42. .如果真 (值 = -2147483648)
  43.     返回 (“-214,748,364,8”)
  44. .如果真结束
  45. 负数 = 值 < 0
  46. .如果真 (负数)
  47.     值 = 0 - 值
  48. .如果真结束
  49. 文本整数 = 到文本 (值)
  50. 长度 = 取文本长度 (文本整数)
  51. 返回值 = 取文本左边 (文本整数, (长度 - 1) % 3 + 1) + “,”
  52. .变量循环首 (取文本长度 (返回值), 长度, 3, 计数)
  53.     返回值 = 返回值 + 取文本中间 (文本整数, 计数, 3) + “,”
  54. .变量循环尾 ()
  55. 返回 (选择 (负数, “-”, “”) + 取文本左边 (返回值, 取文本长度 (返回值) - 1))


  56. .子程序 长整数型_三位分节, 文本型, 公开, 输入:12345 输出 12,345 (支持负数)
  57. .参数 值, 长整数型
  58. .局部变量 负数, 逻辑型
  59. .局部变量 文本整数, 文本型
  60. .局部变量 分段, 文本型, , "0"
  61. .局部变量 计数, 整数型
  62. .局部变量 返回值, 文本型
  63. .局部变量 长度, 整数型

  64. .如果真 (值 = 取字节集数据 ({ 0, 0, 0, 0, 0, 0, 0, 128 }, #长整数型, ))
  65.     返回 (“-9,223,372,036,854,775,808”)
  66. .如果真结束
  67. 负数 = 值 < 0
  68. .如果真 (负数)
  69.     值 = 0 - 值
  70. .如果真结束
  71. 文本整数 = 到文本 (值)
  72. 长度 = 取文本长度 (文本整数)
  73. 返回值 = 取文本左边 (文本整数, (长度 - 1) % 3 + 1) + “,”
  74. .变量循环首 (取文本长度 (返回值), 长度, 3, 计数)
  75.     返回值 = 返回值 + 取文本中间 (文本整数, 计数, 3) + “,”
  76. .变量循环尾 ()
  77. 返回 (选择 (负数, “-”, “”) + 取文本左边 (返回值, 取文本长度 (返回值) - 1))

复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则