设为首页收藏本站帮助中心
查看: 38|回复: 0
收起左侧

易语言实现取随机汉字 只能取系统核心支持库收录拼音的中文汉字文字 (返回文本型)

[复制链接]
发表于 7 天前 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1
  3. .程序集变量 汉字表, 文本型, , "0"
  4. .程序集变量 汉字数, 整数型

  5. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码
  6. .局部变量 计数, 整数型
  7. .局部变量 汉字, 文本型

  8. 置随机数种子 ()
  9. .变量循环首 (-32768, 32767, 1, 计数)
  10.     汉字 = 到文本 (到字节集 (到短整数 (计数)))
  11.     .如果真 (取发音数目 (汉字) ≠ 0)
  12.         加入成员 (汉字表, 汉字)
  13.     .如果真结束

  14. .变量循环尾 ()
  15. 汉字数 = 取数组成员数 (汉字表)

  16. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  17. 返回 (0)  ' 可以根据您的需要返回任意数值

  18. .子程序 _临时子程序

  19. 信息框 (取随机汉字 (100), 0, , )


  20. .子程序 取随机汉字, 文本型, 公开, 只能取核心库收录拼音的汉字
  21. .参数 字数, 整数型
  22. .局部变量 文件号, 整数型
  23. .局部变量 返回值, 文本型

  24. .如果真 (字数 ≤ 0)
  25.     返回 (“”)
  26. .如果真结束
  27. 文件号 = 打开内存文件 ()
  28. .计次循环首 (字数, )
  29.     写出文本 (文件号, 汉字表 [取随机数 (1, 汉字数)])
  30. .计次循环尾 ()
  31. 移动读写位置 (文件号, #文件首, 0)
  32. 读入数据 (文件号, 返回值)
  33. 关闭文件 (文件号)
  34. 返回 (返回值)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则