设为首页收藏本站帮助中心
查看: 15|回复: 0
收起左侧

易语言实现所有基本类型数组的查询并防重复加入成员 (返回整数型)

[复制链接]
发表于 3 天前 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 A, 字节型, , "0"
  9. .局部变量 B, 短整数型, , "0"

  10. .计次循环首 (5000, )
  11.     字节型数组_查询并加入成员_防重复 (A, 取随机数 (, ))
  12. .计次循环尾 ()
  13. .计次循环首 (50000, )
  14.     短整数型数组_查询并加入成员_防重复 (B, 取随机数 (, ) × 取随机数 (, ))
  15. .计次循环尾 ()

  16. 调试输出 (A)
  17. 调试输出 (B)

  18. .子程序 字节型数组_查询并加入成员_防重复, 整数型, 公开
  19. .参数 欲加入成员的数组变量, 字节型, 参考 数组
  20. .参数 欲加入的成员数据, 字节型
  21. .局部变量 索引, 整数型

  22. .计次循环首 (取数组成员数 (欲加入成员的数组变量), 索引)
  23.     .如果真 (欲加入成员的数组变量 [索引] = 欲加入的成员数据)
  24.         返回 (索引)
  25.     .如果真结束

  26. .计次循环尾 ()
  27. 加入成员 (欲加入成员的数组变量, 欲加入的成员数据)
  28. 返回 (索引)


  29. .子程序 整数型数组_查询并加入成员_防重复, 整数型, 公开
  30. .参数 欲加入成员的数组变量, 整数型, 参考 数组
  31. .参数 欲加入的成员数据, 整数型
  32. .局部变量 索引, 整数型

  33. .计次循环首 (取数组成员数 (欲加入成员的数组变量), 索引)
  34.     .如果真 (欲加入成员的数组变量 [索引] = 欲加入的成员数据)
  35.         返回 (索引)
  36.     .如果真结束

  37. .计次循环尾 ()
  38. 加入成员 (欲加入成员的数组变量, 欲加入的成员数据)
  39. 返回 (索引)

  40. .子程序 小数型数组_查询并加入成员_防重复, 整数型, 公开
  41. .参数 欲加入成员的数组变量, 小数型, 参考 数组
  42. .参数 欲加入的成员数据, 小数型
  43. .局部变量 索引, 整数型

  44. .计次循环首 (取数组成员数 (欲加入成员的数组变量), 索引)
  45.     .如果真 (欲加入成员的数组变量 [索引] = 欲加入的成员数据)
  46.         返回 (索引)
  47.     .如果真结束

  48. .计次循环尾 ()
  49. 加入成员 (欲加入成员的数组变量, 欲加入的成员数据)
  50. 返回 (索引)

  51. .子程序 逻辑型数组_查询并加入成员_防重复, 整数型, 公开
  52. .参数 欲加入成员的数组变量, 逻辑型, 参考 数组
  53. .参数 欲加入的成员数据, 逻辑型
  54. .局部变量 索引, 整数型

  55. .计次循环首 (取数组成员数 (欲加入成员的数组变量), 索引)
  56.     .如果真 (欲加入成员的数组变量 [索引] = 欲加入的成员数据)
  57.         返回 (索引)
  58.     .如果真结束

  59. .计次循环尾 ()
  60. 加入成员 (欲加入成员的数组变量, 欲加入的成员数据)
  61. 返回 (索引)

  62. .子程序 文本型数组_查询并加入成员_防重复, 整数型, 公开
  63. .参数 欲加入成员的数组变量, 文本型, 参考 数组
  64. .参数 欲加入的成员数据, 文本型
  65. .局部变量 索引, 整数型

  66. .计次循环首 (取数组成员数 (欲加入成员的数组变量), 索引)
  67.     .如果真 (欲加入成员的数组变量 [索引] = 欲加入的成员数据)
  68.         返回 (索引)
  69.     .如果真结束

  70. .计次循环尾 ()
  71. 加入成员 (欲加入成员的数组变量, 欲加入的成员数据)
  72. 返回 (索引)

  73. .子程序 字节集数组_查询并加入成员_防重复, 整数型, 公开
  74. .参数 欲加入成员的数组变量, 字节集, 参考 数组
  75. .参数 欲加入的成员数据, 字节集
  76. .局部变量 索引, 整数型

  77. .计次循环首 (取数组成员数 (欲加入成员的数组变量), 索引)
  78.     .如果真 (欲加入成员的数组变量 [索引] = 欲加入的成员数据)
  79.         返回 (索引)
  80.     .如果真结束

  81. .计次循环尾 ()
  82. 加入成员 (欲加入成员的数组变量, 欲加入的成员数据)
  83. 返回 (索引)

  84. .子程序 短整数型数组_查询并加入成员_防重复, 整数型, 公开
  85. .参数 欲加入成员的数组变量, 短整数型, 参考 数组
  86. .参数 欲加入的成员数据, 短整数型
  87. .局部变量 索引, 整数型

  88. .计次循环首 (取数组成员数 (欲加入成员的数组变量), 索引)
  89.     .如果真 (欲加入成员的数组变量 [索引] = 欲加入的成员数据)
  90.         返回 (索引)
  91.     .如果真结束

  92. .计次循环尾 ()
  93. 加入成员 (欲加入成员的数组变量, 欲加入的成员数据)
  94. 返回 (索引)

  95. .子程序 长整数型数组_查询并加入成员_防重复, 整数型, 公开
  96. .参数 欲加入成员的数组变量, 长整数型, 参考 数组
  97. .参数 欲加入的成员数据, 长整数型
  98. .局部变量 索引, 整数型

  99. .计次循环首 (取数组成员数 (欲加入成员的数组变量), 索引)
  100.     .如果真 (欲加入成员的数组变量 [索引] = 欲加入的成员数据)
  101.         返回 (索引)
  102.     .如果真结束

  103. .计次循环尾 ()
  104. 加入成员 (欲加入成员的数组变量, 欲加入的成员数据)
  105. 返回 (索引)

  106. .子程序 日期时间型数组_查询并加入成员_防重复, 整数型, 公开
  107. .参数 欲加入成员的数组变量, 日期时间型, 参考 数组
  108. .参数 欲加入的成员数据, 日期时间型
  109. .局部变量 索引, 整数型

  110. .计次循环首 (取数组成员数 (欲加入成员的数组变量), 索引)
  111.     .如果真 (欲加入成员的数组变量 [索引] = 欲加入的成员数据)
  112.         返回 (索引)
  113.     .如果真结束

  114. .计次循环尾 ()
  115. 加入成员 (欲加入成员的数组变量, 欲加入的成员数据)
  116. 返回 (索引)

  117. .子程序 子程序指针数组_查询并加入成员_防重复, 整数型, 公开
  118. .参数 欲加入成员的数组变量, 子程序指针, 参考 数组
  119. .参数 欲加入的成员数据, 子程序指针
  120. .局部变量 索引, 整数型

  121. .计次循环首 (取数组成员数 (欲加入成员的数组变量), 索引)
  122.     .如果真 (欲加入成员的数组变量 [索引] = 欲加入的成员数据)
  123.         返回 (索引)
  124.     .如果真结束

  125. .计次循环尾 ()
  126. 加入成员 (欲加入成员的数组变量, 欲加入的成员数据)
  127. 返回 (索引)

  128. .子程序 双精度小数型数组_查询并加入成员_防重复, 整数型, 公开
  129. .参数 欲加入成员的数组变量, 双精度小数型, 参考 数组
  130. .参数 欲加入的成员数据, 双精度小数型
  131. .局部变量 索引, 整数型

  132. .计次循环首 (取数组成员数 (欲加入成员的数组变量), 索引)
  133.     .如果真 (欲加入成员的数组变量 [索引] = 欲加入的成员数据)
  134.         返回 (索引)
  135.     .如果真结束

  136. .计次循环尾 ()
  137. 加入成员 (欲加入成员的数组变量, 欲加入的成员数据)
  138. 返回 (索引)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则