设为首页收藏本站帮助中心
查看: 125|回复: 0
收起左侧

易语言实现将文本HTML代码转换到JavaScript代码 (返回文本型)

[复制链接]
发表于 2021-1-15 11:25:25 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 置剪辑板文本 (HTML转JavaScript (#HTML代码))

  9. .子程序 HTML转JavaScript, 文本型, 公开
  10. .参数 HTML代码, 文本型
  11. .局部变量 分割, 文本型, , "0"
  12. .局部变量 文件号, 整数型
  13. .局部变量 行, 整数型
  14. .局部变量 返回值, 文本型

  15. 分割 = 分割文本 (HTML代码, #换行符, )
  16. 文件号 = 打开内存文件 ()
  17. .计次循环首 (取数组成员数 (分割), 行)
  18.     写文本行 (文件号, HTML转JavaScript_单行 (分割 [行]))
  19. .计次循环尾 ()
  20. 移动读写位置 (文件号, #文件首, 0)
  21. 返回值 = 读入文本 (文件号, 取文件长度 (文件号))
  22. 关闭文件 (文件号)
  23. 返回 (返回值)


  24. .子程序 HTML转JavaScript_单行, 文本型
  25. .参数 代码, 文本型
  26. .局部变量 返回值, 文本型

  27. 返回值 = 子文本替换 (代码, “\”, “\/\/”, , , 假)
  28. 返回值 = 子文本替换 (返回值, #引号, “'”, , , 假)
  29. 返回值 = 子文本替换 (返回值, “'”, “\'”, , , 假)
  30. 返回 (“document.writeln(” + #引号 + 返回值 + #引号 + “);”)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则