设为首页收藏本站帮助中心
查看: 910|回复: 0
收起左侧

易语言实现判断 求平方根() 是否计算正确 并将出错结果写入数组 (返回逻辑型)

[复制链接]
发表于 2021-1-16 19:03:30 | 显示全部楼层 |阅读模式
1.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 数值, 双精度小数型
  9. .局部变量 出错表, 双精度小数型, , "0"
  10. .局部变量 出错, 整数型

  11. .判断循环首 (数值 < 100000000000)
  12.     .如果真 (求平方根_是否计算正确 (数值) = 假)
  13.         输出调试文本 (数值)
  14.         加入成员 (出错表, 数值)
  15.         出错 = 出错 + 1
  16.         .如果真 (出错 ≥ 100)
  17.             跳出循环 ()
  18.         .如果真结束

  19.     .如果真结束
  20.     数值 = 数值 + 1
  21. .判断循环尾 ()
  22. 调试输出 (出错表)

  23. .子程序 求平方根_是否计算正确, 逻辑型, 公开
  24. .参数 数值, 双精度小数型
  25. .局部变量 平方根, 双精度小数型

  26. 平方根 = 求平方根 (数值)
  27. 返回 (平方根 × 平方根 = 数值)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则