设为首页收藏本站帮助中心
查看: 698|回复: 0
收起左侧

易语言MASM置入代码实现 取灰度的颜色值 返回 (取颜色值 (灰度,灰度,灰度)) (整数型)

[复制链接]
发表于 2021-1-19 17:44:18 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 灰度, 整数型

  8. .变量循环首 (0, 255, 1, 灰度)
  9.     .如果 (取颜色值_灰度 (灰度) = 取颜色值 (灰度, 灰度, 灰度))
  10.         输出调试文本 (灰度)
  11.     .否则
  12.         暂停 ()
  13.     .如果结束

  14. .变量循环尾 ()


  15. .子程序 取颜色值_灰度, 整数型, 公开, 置入代码:返回 (取颜色值 (灰度, 灰度, 灰度))
  16. .参数 灰度, 字节型, , 数值范围从 0 到 255,表示颜色中的灰度成份。

  17. 置入代码 ({ 51, 192, 138, 69, 8, 193, 224, 8, 138, 69, 8, 193, 224, 8, 138, 69, 8, 201, 194, 4, 0 })
  18. ' xor eax,eax
  19. ' mov al,[ebp+8]
  20. ' shl eax,8
  21. ' mov al,[ebp+8]
  22. ' shl eax,8
  23. ' mov al,[ebp+8]
  24. ' leave
  25. ' retn 4
  26. 返回 (0)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则