设为首页收藏本站帮助中心
查看: 1412|回复: 0
收起左侧

易语言实现两个双精度小数型的一维数组卷积计算公式算法 (返回逻辑型)

[复制链接]
发表于 2021-2-16 20:24:11 | 显示全部楼层 |阅读模式
本帖最后由 CNWTEPRG 于 2021-2-16 20:23 编辑

1.png
输入:
  1. 双精度小数型数组_卷积 ({ 1, 2, 3, 4 }, { 2, 3, 1 }, 输出)
  2. 调试输出 (输出)
  3. 双精度小数型数组_卷积 ({ 1, 2, 3 }, { 4, 5, 6 }, 输出)
  4. 调试输出 (输出)
  5. 双精度小数型数组_卷积 ({ 1.1, 2.2, 3.3 }, { 123.234, 234.345 }, 输出)
  6. 调试输出 (输出)
复制代码

输出:
  1. * 数组:6{2.000000,7.000000,13.000000,19.000000,15.000000,4.000000}
  2. * 数组:5{4.000000,13.000000,28.000000,27.000000,18.000000}
  3. * 数组:4{135.557400,528.894300,922.231200,773.338500}
复制代码
  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 输出, 双精度小数型, , "0"

  9. 双精度小数型数组_卷积 ({ 1, 2, 3, 4 }, { 2, 3, 1 }, 输出)
  10. 调试输出 (输出)
  11. 双精度小数型数组_卷积 ({ 1, 2, 3 }, { 4, 5, 6 }, 输出)
  12. 调试输出 (输出)
  13. 双精度小数型数组_卷积 ({ 1.1, 2.2, 3.3 }, { 123.234, 234.345 }, 输出)
  14. 调试输出 (输出)


  15. .子程序 双精度小数型数组_卷积, 逻辑型, 公开, 卷积计算两个数组,具体算法请查阅相关资料。
  16. .参数 数组A, 双精度小数型, 数组
  17. .参数 数组B, 双精度小数型, 数组
  18. .参数 输出, 双精度小数型, 参考 数组, 卷积计算结果输出,提供数组变量
  19. .局部变量 AA, 整数型
  20. .局部变量 BB, 整数型
  21. .局部变量 A, 整数型
  22. .局部变量 B, 整数型

  23. AA = 取数组成员数 (数组A)
  24. BB = 取数组成员数 (数组B)
  25. .如果真 (AA = 0 或 BB = 0)
  26.     返回 (假)
  27. .如果真结束
  28. 重定义数组 (输出, 假, AA + BB - 1)
  29. .计次循环首 (AA, A)
  30.     .计次循环首 (BB, B)
  31.         输出 [A + B - 1] = 输出 [A + B - 1] + 数组A [A] × 数组B [B]
  32.     .计次循环尾 ()
  33. .计次循环尾 ()
  34. 返回 (真)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则