设为首页收藏本站帮助中心
查看: 820|回复: 0
收起左侧

易语言从图片文件载入位图 支持JPEG、BMP、TIFF、PNG、PCX、PCD等格式 (返回逻辑型)

[复制链接]
发表于 2021-2-24 10:58:18 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png
  1. .版本 2
  2. .支持库 BmpOperate
  3. .支持库 eAPI
  4. .支持库 eImgConverter

  5. .程序集 程序集1

  6. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  7. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  8. 返回 (0)  ' 可以根据您的需要返回任意数值

  9. .子程序 _临时子程序
  10. .局部变量 位图, 位图

  11. .如果真 (位图_载入图片文件 (“in.png”, 位图) = 假)
  12.     信息框 (“载入失败!”, 0, , )
  13.     结束 ()
  14. .如果真结束
  15. 信息框 (格式化文本 (“in.png 的宽度:%d 高度:%d”, 位图.取宽度 (), 位图.取高度 ()), 0, , )


  16. .子程序 位图_载入图片文件, 逻辑型, 公开, 从图片文件载入位图,支持 JPEG、BMP、TIFF、PNG、PCX、PCD 等格式,成功返回真,失败返回假
  17. .参数 图片文件名, 文本型, , 如果是PNG格式,将丢失透明图层
  18. .参数 输出位图, 位图, 参考, 载入后将转换成BMP格式 并以位图数据类型传出,并转换到24位位图
  19. .局部变量 临时文件名, 文本型
  20. .局部变量 成功, 逻辑型

  21. .如果真 (文件头检测 (图片文件名, “BM”))
  22.     返回 (输出位图.载入文件 (图片文件名))
  23. .如果真结束
  24. 临时文件名 = 取临时文件名 ()
  25. .如果真 (转换到BMP (图片文件名, 临时文件名) ≠ 1)
  26.     删除文件 (临时文件名)
  27.     返回 (假)
  28. .如果真结束
  29. 成功 = 输出位图.载入文件 (临时文件名)
  30. .如果真 (输出位图.取位深度 () ≠ 24)
  31.     输出位图 = 输出位图.转换位深度 (24)
  32. .如果真结束
  33. 删除文件 (临时文件名)
  34. 返回 (成功)


  35. .子程序 文件头检测, 逻辑型
  36. .参数 文件名, 文本型
  37. .参数 文件头, 文本型
  38. .局部变量 文件号, 整数型
  39. .局部变量 匹配, 逻辑型

  40. 文件号 = 打开文件 (文件名, #读入, #无限制)
  41. .如果真 (文件号 = 0)
  42.     返回 (假)
  43. .如果真结束
  44. 匹配 = 读入文本 (文件号, 取文本长度 (文件头)) = 文件头
  45. 关闭文件 (文件号)
  46. 返回 (匹配)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则