设为首页收藏本站帮助中心
查看: 824|回复: 0
收起左侧

易语言实现 取整()/绝对取整() (解决核心库返回整数型导致计算溢出,返回双精度小数型)

[复制链接]
发表于 2021-2-27 16:27:29 | 显示全部楼层 |阅读模式

孩子辍学不想上学打工咋办?
来我这免费学:易语言、51单片机、FPGA(IC设计)、PHP Dsicuz! 程序修改、MASM汇编,包教包会,学废为止。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 调试输出 (双精度小数型_绝对取整 (1234567.123457), 绝对取整 (1234567.123457))
  10. 调试输出 (双精度小数型_取整 (1234567.123457), 取整 (1234567.123457))
  11. 调试输出 (双精度小数型_绝对取整 (-1234567.123457), 绝对取整 (-1234567.123457))
  12. 调试输出 (双精度小数型_取整 (-1234567.123457), 取整 (-1234567.123457))



  13. .子程序 双精度小数型_绝对取整, 双精度小数型, 公开, 解决了核心库自带的 绝对取整() 返回整数型导致计算溢出的BUG
  14. .参数 值, 双精度小数型
  15. .局部变量 分割, 文本型, , "0"

  16. 分割 = 分割文本 (到文本 (值), “.”, 2)
  17. 返回 (到数值 (分割 [1]))


  18. .子程序 双精度小数型_取整, 双精度小数型, 公开, 解决了核心库自带的 取整() 返回整数型导致计算溢出的BUG
  19. .参数 值, 双精度小数型
  20. .局部变量 分割, 文本型, , "0"
  21. .局部变量 返回值, 双精度小数型

  22. 分割 = 分割文本 (到文本 (值), “.”, 2)
  23. 返回值 = 到数值 (分割 [1])
  24. .如果真 (返回值 < 0)
  25.     返回值 = 返回值 - 1
  26. .如果真结束
  27. 返回 (返回值)

复制代码

相关帖子

本站源码使用前请注意检查,如有问题请点击右下角举报,将在24小时内得到答复。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则