设为首页收藏本站帮助中心
查看: 598|回复: 0
收起左侧

易语言MASM置入代实现判断整数型数值大小范围是否在最小值到最大值之间 (返回逻辑型)

[复制链接]
发表于 2021-3-9 19:31:40 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
@@@.png
  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 值, 整数型
  9. .局部变量 最小值, 整数型
  10. .局部变量 最大值, 整数型
  11. .局部变量 计数, 整数型
  12. .局部变量 结果, 逻辑型

  13. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  14. 置随机数种子 ()
  15. .判断循环首 (真)
  16.     值 = 取随机数 (, ) × 取随机数 (, ) × 取随机数 (, )
  17.     .循环判断首 ()
  18.         最小值 = 取随机数 (, ) × 取随机数 (, ) × 取随机数 (, )
  19.         最大值 = 取随机数 (, ) × 取随机数 (, ) × 取随机数 (, )
  20.     .循环判断尾 (最小值 > 最大值)
  21.     结果 = 值 ≥ 最小值 且 值 ≤ 最大值
  22.     .如果真 (整数型_是否在范围 (值, 最小值, 最大值) ≠ 结果)
  23.         输出调试文本 (“出错”)
  24.         跳出循环 ()
  25.     .如果真结束
  26.     计数 = 计数 + 1
  27.     .如果真 (计数 ≥ 1000000)
  28.         计数 = 0
  29.         调试输出 (值, 最小值, 最大值, 结果)
  30.     .如果真结束

  31. .判断循环尾 ()

  32. .子程序 整数型_是否在范围, 逻辑型, 公开, 置入代码:返回 (值 ≥ 最小值 且 值 ≤ 最大值)
  33. .参数 值, 整数型
  34. .参数 最小值, 整数型
  35. .参数 最大值, 整数型

  36. 置入代码 ({ 139, 69, 8, 59, 69, 12, 124, 12, 59, 69, 16, 127, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 12, 0 })
  37. ' mov eax,[ebp+8]
  38. ' .if sdword ptr eax >= [ebp+12] && sdword ptr eax <= [ebp+16]
  39. ' mov eax,1
  40. ' .elseif
  41. ' xor eax,eax
  42. ' .endif
  43. ' leave
  44. ' retn 12

  45. 返回 (假)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则