设为首页收藏本站帮助中心
查看: 851|回复: 0
收起左侧

易语言 已知时分秒毫秒 计算出指针钟表的时针、分针、秒针 指针的角度 (返回逻辑型)

[复制链接]
发表于 2021-3-14 23:34:59 | 显示全部楼层 |阅读模式

孩子辍学不想上学打工咋办?
来我这免费学:易语言、51单片机、FPGA(IC设计)、PHP Dsicuz! 程序修改、MASM汇编,包教包会,学废为止。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
本帖最后由 CNWTEPRG 于 2021-3-14 23:38 编辑

1.png
  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 时角度, 双精度小数型
  9. .局部变量 分角度, 双精度小数型
  10. .局部变量 秒角度, 双精度小数型
  11. .局部变量 时, 整数型
  12. .局部变量 秒, 整数型
  13. .局部变量 分, 整数型
  14. .局部变量 时间, 日期时间型

  15. .变量循环首 (0, 11, 1, 时)
  16.     .变量循环首 (0, 59, 1, 分)
  17.         .变量循环首 (0, 59, 1, 秒)
  18.             检查 (时分秒到指针角度 (时, 分, 秒, 时角度, 分角度, 秒角度))
  19.             调试输出 (时, 分, 秒, 时角度, 分角度, 秒角度)
  20.         .变量循环尾 ()
  21.     .变量循环尾 ()
  22. .变量循环尾 ()


  23. .子程序 时分秒到指针角度, 逻辑型, 公开, 将时分秒转换到时针、分针、秒针的角度 (0度指向12点)
  24. .参数 时, 字节型, , 范围:0~11 (如果为24小时制,将转换为12小时制)
  25. .参数 分, 字节型, , 范围:0~59
  26. .参数 秒, 双精度小数型, , 范围:0~59 (小数部分为毫秒)
  27. .参数 时角度, 双精度小数型, 参考, (变量)范围:0~360
  28. .参数 分角度, 双精度小数型, 参考, (变量)范围:0~360
  29. .参数 秒角度, 双精度小数型, 参考, (变量)范围:0~360

  30. .如果真 (时 < 0 或 分 < 0 或 秒 < 0 或 时 > 23 或 分 > 59 或 秒 > 59)
  31.     返回 (假)
  32. .如果真结束
  33. .版本 2

  34. 时角度 = (时 % 12) × 30 + 分 ÷ 2 + 秒 ÷ 120
  35. 分角度 = 分 × 6 + 秒 ÷ 10
  36. 秒角度 = 秒 × 6

  37. 返回 (真)

复制代码

相关帖子

本站源码使用前请注意检查,如有问题请点击右下角举报,将在24小时内得到答复。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则