设为首页收藏本站帮助中心
查看: 1287|回复: 1
收起左侧

易语言实现 求平方根() 计算数值平方根 (解决核心库不支持负数计算,返回双精度小数型)

[复制链接]
发表于 2021-3-17 19:51:48 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2
  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码

  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. 输出调试文本 (求平方根2 (-256), 求平方根 (-256))
  8. 输出调试文本 (求平方根2 (-12345), 求平方根 (-12345))

  9. .子程序 求平方根2, 双精度小数型, 公开, 返回指定参数的平方根,支持负数运算。
  10. .参数 欲求其平方根的数值, 双精度小数型
  11. .局部变量 返回值, 双精度小数型

  12. 返回值 = 求平方根 (取绝对值 (欲求其平方根的数值))
  13. 返回 (选择 (欲求其平方根的数值 < 0, -返回值, 返回值))
复制代码


相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则