设为首页收藏本站帮助中心
查看: 667|回复: 0
收起左侧

易语言实现子程序指针数组的大小排序 解决 数组排序() 无法排序该数据类型 (无返回值)

[复制链接]
发表于 2021-3-28 18:04:31 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
* “排序前” | 数组:10{(子程序地址:1985363062),(子程序地址:403312577),(子程序地址:1934417888),(子程序地址:35997351),(子程序地址:1223475697),(子程序地址:-1034615929),(子程序地址:447385412),(子程序地址:-1655208585),(子程序地址:-273892215),(子程序地址:-35712288)}
* “排序后(从大到小)” | 数组:10{(子程序地址:1985363062),(子程序地址:1934417888),(子程序地址:1223475697),(子程序地址:447385412),(子程序地址:403312577),(子程序地址:35997351),(子程序地址:-35712288),(子程序地址:-273892215),(子程序地址:-1034615929),(子程序地址:-1655208585)}
* “排序后(从小到大)” | 数组:10{(子程序地址:-1655208585),(子程序地址:-1034615929),(子程序地址:-273892215),(子程序地址:-35712288),(子程序地址:35997351),(子程序地址:403312577),(子程序地址:447385412),(子程序地址:1223475697),(子程序地址:1934417888),(子程序地址:1985363062)}

1.png
  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 数组, 子程序指针, , "10"
  9. .局部变量 计数, 整数型

  10. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  11. 置随机数种子 ()
  12. .计次循环首 (10, 计数)
  13.     数组 [计数] = 取随机子程序指针 ()
  14. .计次循环尾 ()

  15. 调试输出 (“排序前”, 数组)
  16. 数组排序_子程序指针 (数组, 假)
  17. 调试输出 (“排序后(从大到小)”, 数组)
  18. 数组排序_子程序指针 (数组, 真)
  19. 调试输出 (“排序后(从小到大)”, 数组)



  20. .子程序 数组排序_子程序指针, , 公开, 核心库的 数组排序() 不支持子程序指针数组处理,此函数可实现子程序指针数组的排序。
  21. .参数 数值数组变量, 子程序指针, 参考 数组, 提供参数数据时只能提供子程序指针数组。
  22. .参数 排序方向是否为从小到大, 逻辑型, 可空, 可以被省略。如果参数值为真,排序方向为从小到大,否则为从大到小。如果本参数被省略,默认值为真。
  23. .局部变量 整数型数组, 整数型, , "0"

  24. 强制交换变量 (整数型数组, 数值数组变量)
  25. 数组排序 (整数型数组, 选择 (是否为空 (排序方向是否为从小到大), 真, 排序方向是否为从小到大))
  26. 强制交换变量 (整数型数组, 数值数组变量)

  27. .子程序 取随机子程序指针, 子程序指针
  28. .局部变量 字节集, 字节集
  29. .局部变量 计数, 整数型

  30. 字节集 = 取空白字节集 (4)
  31. .计次循环首 (4, 计数)
  32.     字节集 [计数] = 取随机数 (, )
  33. .计次循环尾 ()
  34. 返回 (取字节集数据 (字节集, #子程序指针型, ))

复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则