设为首页收藏本站帮助中心
查看: 1438|回复: 2
收起左侧

易语言MASM置入代码实现子程序指针的大于、小于、大于等于、小于等于比较(返回逻辑型)

[复制链接]
发表于 2021-3-31 19:16:54 | 显示全部楼层 |阅读模式
11.png
  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序

  8. 调试输出 (&A, &B, 子程序指针_大于 (&A, &B))
  9. 调试输出 (&C, &D, 子程序指针_小于 (&C, &D))
  10. 调试输出 (&E, &F, 子程序指针_大于等于 (&E, &F))
  11. 调试输出 (&G, &H, 子程序指针_小于等于 (&G, &H))



  12. .子程序 子程序指针_大于, 逻辑型, 公开
  13. .参数 被比较值, 子程序指针
  14. .参数 比较值, 子程序指针

  15. 置入代码 ({ 139, 69, 8, 59, 69, 12, 126, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  16. ' mov eax,[ebp+8]
  17. ' .if sdword ptr eax > [ebp+12]
  18. ' mov eax,1
  19. ' .else
  20. ' xor eax,eax
  21. ' .endif
  22. ' leave
  23. ' retn 8
  24. 返回 (假)

  25. .子程序 子程序指针_小于, 逻辑型, 公开
  26. .参数 被比较值, 子程序指针
  27. .参数 比较值, 子程序指针

  28. 置入代码 ({ 139, 69, 8, 59, 69, 12, 125, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  29. ' mov eax,[ebp+8]
  30. ' .if sdword ptr eax < [ebp+12]
  31. ' mov eax,1
  32. ' .else
  33. ' xor eax,eax
  34. ' .endif
  35. ' leave
  36. ' retn 8
  37. 返回 (假)

  38. .子程序 子程序指针_大于等于, 逻辑型, 公开
  39. .参数 被比较值, 子程序指针
  40. .参数 比较值, 子程序指针

  41. 置入代码 ({ 139, 69, 8, 59, 69, 12, 124, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  42. ' mov eax,[ebp+8]
  43. ' .if sdword ptr eax >= [ebp+12]
  44. ' mov eax,1
  45. ' .else
  46. ' xor eax,eax
  47. ' .endif
  48. ' leave
  49. ' retn 8
  50. 返回 (假)

  51. .子程序 子程序指针_小于等于, 逻辑型, 公开
  52. .参数 被比较值, 子程序指针
  53. .参数 比较值, 子程序指针

  54. 置入代码 ({ 139, 69, 8, 59, 69, 12, 127, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  55. ' mov eax,[ebp+8]
  56. ' .if sdword ptr eax <= [ebp+12]
  57. ' mov eax,1
  58. ' .else
  59. ' xor eax,eax
  60. ' .endif
  61. ' leave
  62. ' retn 8
  63. 返回 (假)

  64. .子程序 A



  65. .子程序 B



  66. .子程序 C



  67. .子程序 D



  68. .子程序 E



  69. .子程序 F



  70. .子程序 G



  71. .子程序 H


复制代码

相关帖子

回复

使用道具 举报

发表于 2021-4-2 16:19:27 | 显示全部楼层

代替整数型
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则